Support: PRIME: is it supported? no

What happens if you see the error message “PRIME: is it supported? no” in the terminal when launching nvidia-settings application to configure your NVIDIA card on your Optimus system?

Most probably there has been some issues when updating the driver or wrong configuration. The way to fix this is quite simple (tested on Ubuntu and Lubuntu 14.04):

First of all let’s remove NVIDIA drivers:
sudo apt-get purge bumblebee*
sudo apt-get purge nvidia-*

Then reboot the computer and install the latest version (in my case was nvidia-331-updates):

sudo apt-get install nvidia-331-updates

this will install nvidia-settings and nvidia-prime and reboot one last time – your configuration is now correct!

Incoming search terms:

  • prime is it supported no
  • Ubuntu prime supported no

There are 2 comments left Go To Comment

  1. hammy /

    Not working 🙂

    1. Stefano Prenna
      Stefano Prenna / Post Author

      I’m sorry to hear that! Do you have some extra information (like error message, logs, etc.)?

Leave a Reply